Articles on: Meta Ads for Shopify

How to Resolve The "you won't be able to create or modify ads until you've authenticated your account" Error

Error


You encounter the following error when you launch ads:


"We think that someone may have tried to access your account without permission. For your protection, you won't be able to create or modify ads until you've authenticated your account in Ads Manager. Your existing ads will continue to run normally".


Cause


This restriction is applied by Facebook when it detects unusual activity, such as:

  • Log in from a new or unexpected location
  • Sudden IP address changes
  • VPN or proxy usage

To protect your ad account, Facebook requires account authentication before allowing you to launch ads.


Step 1: Open your Ads Manager


  1. Go to: http://business.facebook.com/adsmanager to open your Ads Manager.
  2. Ensure you're logged in to the ad account you want to use.


Ads Manager Dashboard

Step 2: Go to your Ad Account


  1. In your Ads Manager, click on the sidebar.

Ads Manager Sidebar

  1. Click on "Billing and payments".

Billing and Payments


Step 3: Authenticate your Ad Account


  1. After you open your ad account, click on "Start Authentication".


Facebook Ad Account

  1. Add your email address.
  2. Click on "Send Code".
  3. Open your email inbox to copy the code and paste it.


Step 4: Return to Easy Ads


  1. Return to Easy Ads.
  2. Refresh your screen
  3. Relaunch your ads.


Additional Tips


If you followed these steps, but the problem isn't solved yet. Then, you need to review your account status in Facebook’s Account Quality. You should ensure that your ad account complies with Facebook community guidelines.


Still need help?


No worries! You can contact our support team at support@easyadsapp.com. We would love to help!


Updated on: 24/12/2025

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