How to Resolve The "you won't be able to create or modify ads until you've authenticated your account" Error
Error
You encounter the following error when you launch ads:
Cause
This restriction is applied by Facebook when it detects unusual activity, such as:
- Log in from a new or unexpected location
- Sudden IP address changes
- VPN or proxy usage
To protect your ad account, Facebook requires account authentication before allowing you to launch ads.
Step 1: Open your Ads Manager
- Go to: http://business.facebook.com/adsmanager to open your Ads Manager.
- Ensure you're logged in to the ad account you want to use.

Step 2: Go to your Ad Account
- In your Ads Manager, click on the sidebar.

- Click on "Billing and payments".

Step 3: Authenticate your Ad Account
- After you open your ad account, click on "Start Authentication".

- Add your email address.
- Click on "Send Code".
- Open your email inbox to copy the code and paste it.
Step 4: Return to Easy Ads
- Return to Easy Ads.
- Refresh your screen
- Relaunch your ads.
Additional Tips
If you followed these steps, but the problem isn't solved yet. Then, you need to review your account status in Facebook’s Account Quality. You should ensure that your ad account complies with Facebook community guidelines.
Still need help?
No worries! You can contact our support team at support@easyadsapp.com. We would love to help!
Updated on: 24/12/2025
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